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BP and Vendor number is Different

SPRO->SAP Reference IMG->Financial Accounting->Accounts Receivable and Payable->Vendor
Accounts->Master Data->Preparation of creating vendor master data->Define account groups with
screen layout (vendors)

New Entries: Details of Added Entries

Expand Field Status TF 4 P =

Account group DIL1

General data

=
Meaning  Domestic Datg|
One-Time Account ]

Skip Address Check

Field status

General Data
Company Code Data
Purchasing Data

Create Number Range for Account Group (XKN1):

SPRO->SAP Reference IMG->Financial Accounting->Accounts Receivable and Payable->Vendor
Accounts->Master Data->Preparation of creating vendor master data->Create number ranges for
vendor accounts

Edit Intervals: Vendor, Object KREDITOR

0 L BB BB

Number Range No. From No. To Number NR Status External m
A 99999993930 9999999999 ] (V] —
.D 0300020000 :0300029999 :0 | e
01 0000000001 0000499999 45 O

07 7000010000 7000010100 0 (v

15 0001500000 0001500100 0 0

27 0400100000 0400100100 0 (v

A2 150 1999 0

Assign Number Range to account groups (OBAS):

1<)

SPRO->SAP Reference IMG->Financial Accounting->Accounts Receivable and Payable->Vendor
Accounts->Master Data->Preparation of creating vendor master data->Assign Number range to

vendor account groups
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Change View "Assign Vendor Account Groups->N
o Al B L E P

Group Name Number range
r
DIL1 Domestic Data D _, -~

Define Business Partner Number Range:

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->Number Ranges and Groupings->Define number ranges

Edit Intervals: Business partner, Object BU_PARTNER
¢ £ BEBEIEBRRE

Number Range No. From No. To Number NR Status External
A 99999999390 9999999999 9999999999 Lt
T A —

J.E |!2000009999 _12000050000 0 []

Assign Business Partner Number range to Grouping:
SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->Number Ranges and Groupings->Define Groupings and assign number ranges

New Entries: Overview of Added Entries

PEE®RE R

Grouping Short name Description Number ra... External Int.Std.Grpi... Ext.Std Gr|:

-1 =
GRP1 GRP1 GRP1 Grouping for BP .E| Q| -

L
o v

Link Grouping and Account Group:

SPRO->SAP Reference IMG->Cross Application Components->Master Data Synchronization-
>Custom/Vendor integration->Business Partner Settings->Settings for vendor integration->Field
assighment for vendor integration->Assign Keys->Define number assignment for direction BP to

vendor

****De-Select Same number range****
New Entries: Overview of Added Entries
B R E

Business Partner: Assignment of Account Groups and Grouping

Grp. Short name Group Meaning Same Nos. Flex. Grp.
GRP1 GRP1 DIL1 Domestic Data B [
™ 1

' = =
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Created BP

‘ Display Organization: 2000009999, role Supplier (Fin.Accounting)

[ | [Mperson [Yorganzaton [NGroup | < o> | 88 o GeneralData Company Code = Relationships | &7

Business Partner 2000009999 fy TEST1 BP/Vendor Dff / 565656 Hyderabad
Display in BP role [FLVNOO Supplier (Fin.Accou... "@]

~ Address }/Addres Overview }/Identiﬁcation YContmI YPayment Transactions Ystztus /" Legal Data / Ven(

Vendor: Tax Data }/Vendor: Texts

Vendor Number
Vendor Number 300020000
Vendor Assignment
-
Account group LbILl_'ljl Lomestic Data Maintain Acc Grp

BP: 2000009999

Vendor: 300020000

LFA1: Display of Entries Found

ZE N ORE|

Search in Table [zF21 | Supplier Master (General Section)
Number of hits [x |

Runtime 0 Maximum no. of hits 500

Insert Column -.
@III@. Bl sl (Sl J& JEHL) 1)) [ Aoeti|®]

B LWendor JCty |Name 1 |Name 2 Name 3 Name 4/ City |District PO Box PO Box pcd Post.Code Rg | Search term Street Address Name 1 |Name 2/City | Title

D 300020000 N TEST1 BP/Vendor Diff Hyderabad 565656 27014 TEST1 BP/VENDOR DIFF HYDERABAD Company
LFB1: Display of Entries Found
9 & B &
Search in Table 'LFB1 | Vendor Master (Company Code)
Number of hits 1 |
I o1l
Runtime 0 | Maximum no. of hits /500 |

Insert Column \ @@]
IR EE

B Vendor \CoCode |Pers.No.
300020000  KUSH 03.06.2021 TRNE134 4400

| 4

s [E]@ B JEL) (@) (Apesis|[®)

Created on Created by B DelF Sort Recon.acct AuGr Int.Indic. Met
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LFM1: Display of Entries Found

3B 3
Search in Table |LFM1 | Vendor master record purchasing organization data
Number of hits f1 l
I ol
Runtime l00:00:01 | Maximum no. of hits [s00 ]

Insert Column ' ]
B0 EFE BLEL EE B JEL ) ([@ess]®)

B Supplier POrg  |Created on  Created B D |ABC Crcy Salespers. Telephone Min. value PayT IncoT Inco. 2
u 300020000 CORG 03.06.2021 TRNE134

] BUTO000: Display of Entries Found

9 & B 3
Search in Table [BUTO00 | BP: General data I
Number of hits [1 |
Runtime lo | Maximum no. of hits 500

Insert Column 1 ..
S II.IUDI[_LIIﬁ[m /I [2]& J&) JE L) (]| [ Moetats [ ®)]

B BusinessPartner BPC Type Grp.  Extern.No. SrchTerm 1 SrchTerm 2 Origin Title | C/R Ra... Name 1 ‘Nam
u[zooooosmqﬂz GRP1 0003 TEST1 BP/Vendor Diff

BUT100: Display of Entries Found

9 I B F
Search in Table 'BUT100 | BP: Roles
Number of hits 2 l
I o1l
Runtime 0 | Maximum no. of hits |_500 !
Insert Column | L3 " E) |
P . “‘ Det}n

B2 Business Partner BP Role DIfT ypeVaI\ Valld From] Valld To \RType\AGrp

2000009999 FLVNOO 20.210.603.000.000 99.991.231.235.959

2000009999 FLVNO1 20.210.603.000.000 99.991.231.235.959
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BP and Vendor Number is same

Account Group Number Range:

SPRO->SAP Reference IMG->Financial Accounting->Accounts Receivable and Payable->Vendor
Accounts->Master Data->Preparation of creating vendor master data->Create number ranges for
vendor accounts

****Select external tick mark****
.F 0100001000 0100002000 0 (v]
Assign above number range to Account Group:

SPRO->SAP Reference IMG->Financial Accounting->Accounts Receivable and Payable->Vendor
Accounts->Master Data->Preparation of creating vendor master data->Assign Number range to
vendor account groups

Change View "Assign Vendor Account Groups->NA
o BENI G E e

Group Name Number range m
r T
DIL1 Domestic Data oF J -
Business Partner Number Range:

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->Number Ranges and Groupings->Define number ranges

****¥Don’t select External tick mark****
- 0100001000 0100002000 0
Assign Business Partner number range to Grouping:

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->Number Ranges and Groupings->Define Groupings and assign number ranges

Change View "BP groupings": Overview
&% NewEntries [ B2 29 [ M L [e3

Grouping |Short name Description Number ra... External Int.Std.Grpi... |[Ext.Std Grefl]
r =T — .
GRP1 GRP1 GRP1 Grouping for BP - | Q B

Link Grouping and Account Group:

SPRO->SAP Reference IMG->Cross Application Components->Master Data Synchronization-
>Custom/Vendor integration->Business Partner Settings->Settings for vendor integration->Field
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assignment for vendor integration->Assign Keys->Define number assignment for direction BP to

vendor

****Select same number range when linking grouping and account group****
Change View "Business Partner: Assignment of Account
& NeweEntries [[) B2 © [ R L [

Business Partner: Assignment of Account Groups and Grouping

Grp. |Short name Group 'Meaning Same Nos.
—a
GRP1 GRP1 DIL1 Domestic Data L@J

Display Organization: 100001000, role Supplier (Fin.Accounting)

[ [Mperson [ Organizaton [JGroup @ 6% General Data  Company Code | Relationships = &1
Business Partner 100001000 TEST1 BP/Vendor Same / 565656 Banglore
Display in BP role FLVNOO Supplier (Fin.Accou.. ¥

——
Address -~ Address Overview | Identification  Control " Payment Transactions  Status - Legal Data Vendor: General Data k Vendor: Tax Data

¢ Vendor: Texts

Vendor Number
Vendor Number 100001000 |

Vendor Assignment

i T
Account group LbILlJ Jomestic Data Maintain Acc Grp

BP and Vendor: 100001000

Create BP role

BP Role:

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-

>Basic Settings->Business Partner Roles->Define BP Roles
Created BP role as BPCCPR

Change View "BP Roles": Overview

&% & NeweEntries [O B2 B R R R [&

Dialog Structure BP Roles
> E BP Roles » BP Role Title Description
BP Role Categories BKK010
+ (3 BP Role Category —>

BKK020
BKK030
BKK200
=
PPCCPRI _' Bplier (Fin.Accounting) Supplier (Financial Accounting)

Here | have not changed the BP view, we can create own view and assign
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Create customizing view:

TCODE: BUSD

Created KUSHOO customized view copying from FLVNOO and added purchasing details copying from view

FLVNO1 to KUSHOO

Now we have both company code and purchasing data in the same view KUSHOO

Chémge View "BP Views": Overview
&% & NewkEnties [ B2 B [ R B

Dialog Structure View  Description Title i
~ [ BP Views jKUSHOO Customer/Vendor Integration: FI Vendor CVI: FI Vendor —
+ [(3BP View -> Data Set -
) - 1M0001 Processor Processor
+ 3 BP View -> Caling Ar
- BIBP View ->Screen S¢ | [Toor0L Sponsor Sponsor
« CBP View -> Views RCFAGY Agency Agency
+ (8P Role -> Subheade | |[RCFBRA Branch Branch
RFMV01 RFM: Vendor Procurement Monitoring Vendor Procur. Monitoring
Add screen sequence category to have both company code and Purchase Organization
Change View "BP View ->Screen Sequences": Overview
5 nNewEntries [ B2 B F [} B
Dialog Structure BP View KUSHOO|  Customer/Vendor Integration: FI Vendor
¥ [(3BP Views
- Ber V!ew = DaFa et o i BP View ->Screen Segquences
« [Z38P View -> Caling Applications
- = BP View ->Screen Sequences ‘grScm. Seq. Cat. _‘%scription Scrn seq. | Description
« [ BP View -> Views fVIVOll _‘ rchasing Organization-Depend.. CVIVO1 Purchasing Organization-Depend ~
+ (I8P Role -> Subheader ID FS0001 Company Code-Dependent Data FS0001 Company Code-Dependent Data ~

Assign created view KUSHOO to BP role:

7Change View "BP Roles"™ Details
5% NewEntries (DB D & [3 & [&

Dialog Structure BP Role |BRCCER|
* == BP Roles
~ [ BP Role Categories R
+ 8P Role Category —> :
Title Supplier (Fin.Accounting)
Description ‘Supplier (Financial Accounting)
[ IHide

| BP Role Category
BP Role Cat. [FLvnoo|  FI Vendor
[]Std Assignment BP Role -> BP Role Cat.

Additional BP Roles for BP Role Category FLVNOO

BP Role  Title Standard |
CSCL Full Vendor View-CSCL ®
FLV700  Supplier V7 @) =
FLVNOO  Supplier (Fin.Accounting) (@) v
<« «»

Interface Control
[ ———

BP View kUsHOO| Q) CVI: FI Vendor
= ]

Position
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Create Organization: Role Supplier (Fin.Accounting)

[ | [MPerson [ Organization [ Group [') With Reference [=AREN= “z  Company Code Purchasing Relationships | &1

Business Partner Grouping | GRP1 GRP1 Grouping for..v!
Create in BP role |BPCCPR Supplier (Fin.Accou.. ¥ @

./ Address | Address Overview 7{ Identification | Control 1 bayment Transactions | Status | LegalData | Vendor: General Data  Vendor: Tax Data |~ Vendor: Texts |

Name o~

-

Title v
Name ~

Created BP and vendor as same: 100001001
If want to make any field as mandatory or optional or hide based for BP role we can do in below path:

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->Field Groupings->Configure Field Attribute per BP role

Change View "Field Grou BP Role": Overview

Field Grouping %% New Entries [[) B& &9 [ [ [

Field Grouping BP Role
~ BP Role Description

FLVNOO Supplier (Financial Accounting)
[[&'LVNOlbpier -

F50000 Financial Services Business Partner

FSOKNE

FIBOOO

HEAOQ10

HEAOD20

HEA030

HER040

HEAOS50

LOG010

PSSPO1

RTPO10

RTPOS50

SLLSTL

SLLTPD

TM0001 Truck Driver

TRO100 a

TR0O101 v
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Change View "Field Grou BP Role": Overview

Supplier
Supplier
Data Set Fld Groups
Description m Description Fie... Hide Req.entry Opt. entry Display Not spec. m
Vendor: Italy - CUP/CIG “ | |Supplier: Rounding Profile 5503 ® =~
Vendor: Japan - EMC Details ¥ ||supplier: Unit of Measure Group 5504 - ® v
Vendor: Japan DDS Details Vendor Subrange: Sales Person and Telephone 3962 ®
Vendor: Korea - VAT Identificati Vendor: ABC Classes 2030 ®
Vendor: Kuwait - Shareholder Ac Vendor: Account for Vendor 2029 O]
Vendor: Kuwait - Shareholder Dz Vendor: Free Goods 2032 O]
Vendor: Partner Roles Vendor: Minimum Purchase Order Value 2027 (®
mVendor: Purchasing Vendor: Payment Conditions 2025 ®
Vendor: Purchasing Data Vendor: Purchase Order Currency 2024 (®
Vendor: Purchasing Dataset for ' Vendor: Purchasing Organization 2023 O]
Vendor: Qatar - Tax Card Data Vendor: Salesperson, Telephone 2028 ®
Vendor: Subcontracting Suppler Vendor: Shipping Conditions 2031 (e
Vendor: TAN-Based Exemption - Vendor: Subrange 3325 (®
Vendor: Taiwan elnvoice - a
Vendor: Texts v -
« «» «

Field check

Here in the below screen account group is automatically selected because we have linked grouping and
accounting in customer/vendor integration

Create Organization: Role Supplier (Fin.Accounting)

[ | [(person [ Organization [ Group [')With Reference | = | <@ > | % g8 GeneralData  Company Code | Relationships | &1
Business Partner [ ] Grouping GRP1 GRP1 Grouping for..~
Create in BP role FLVNOO Supplier (Fin.Accou... v‘

Address ~ ‘Address Overview  Identification 7( Control " Payment Transactions - Status '( vLegaI Data ~ Vendor: General Data k Vendor: Tax Data

Vendor Number

Vendor Number <External>/
Vendor Assignment
Account group DIL1| Domestic Data

If we want to select externally we need to select flexible group and de-select “same number range”
Or else you get the error as below because different account groups have different number ranges

SPRO->SAP Reference IMG->Cross Application Components->Master Data Synchronization-
>Custom/Vendor integration->Business Partner Settings->Settings for vendor integration->Field
assignment for vendor integration->Assign Keys->Define number assignment for direction BP to
vendor

When linking Grouping and Account Group
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= Performance Assistant

Same Numbers and Flexible Grouping cannot be
combined.

La L o L

Change View "Business Partner: Assignment of Account Groups anc
& NewEntries [ B3 B L M [ [

i' Business Partner: Assignment of Account Groups and Grouping

~ Grp. Short name Group Meaning Same Nos. Flex. Grp.

GRP1 GRP1 DILL Domestic Data ]

Now account group is editable

CIBE Organization: Role Supplier (Fin.Accounting)

[ | (Yperson [ organzation [N Group [ With Reference | 5 | <7 > | %8 g8 General Data  Company Code | Relationships | &1

Business Partner ‘ Grouping GRP1 GRP1 Grouping for..¥
Create in BP role [FLVNOO Supplier (Fin.Accou.. v|&]

Address  Address Overview | Identification ['Control I Payment Transactions | Status  Legal Data / Vendor: General Data k Vendor: Tax Data  Vendor: Te:

Vendor Number =

Vendor Number

| Vendor Assignment
External Vendor No. =
Account group prr1|Fomestic Data

Display Organization: 100001002, role Supplier (Fin.Accounting)

(Bl | [YPerson [YOrganization [NGroup | | & = | &% General Data  Company Code | Relationships | &3
Business Partner 100001002 TEST Vendor with custom role and view / 565656 Ban
I ; - ]
Display in BP role I_FLVNO(] Supplier (Fin.Accou.. v

Address | Address Overview | Identification  Control | Payment Transactions | Status . Legal Data . Vendor: Ge

15

' Vendor Number

Vendor Number 46
| Vendor Assignment
Account group 1000' Domestic Vendor B747 Maintain Acc Grp

| Canarml NaEa

BP and vendor is same: 100001002
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If you want to enter Business Partner number externally then select “external”
When assigning business partner number range to grouping

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->Number Ranges and Groupings->Define Groupings and assign number ranges

Change View "BP groupings": Overview
& NewEntries [ B2 © [ M [ [

Grouping |Short name Description Number ra... External Int.Std.Grpi... Ext.Std GrefT
o r A .
IMP1 LImp KED1 _lImport Vendor KEO1 JW O -

[S Business Partner Edit  Goto Extras  Environment  System  Help

& “«Hd @@ N @

Create Organization: Role Supplier (Fin.Accounting)

[El | [YPerson [")Organization [ Group [ With Reference | = | <o o> | 58 g0 General Data

I o\l

Business Partner | I} Grouping 'IMP1 Import Vendor KE.. ¥ |
Create in BP role |FLVNOO Supplier (Fin.Accou.. ¥ ‘

Address | Address Overview | Identification | Control / Payment Transactions | Status [ L.[] '« [*]

| Name

Title '0003 Company v

Name 'TEST IMP1 Grouping

Salutation

Salutation '
4« «»
@ Grouping Import Vendor KEO1 has external number assignment, enter a number BJ;’ <

Created BP: A90001
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Display Organization: A90001, role Supplier (Fin.Accounting)

- [Nperson [N organization [NGroup | | <o > %% o GeneralData Company Code

Business Partner RA90001 TEST IMP1 Grouping / 565656 Banglore
Display in BP role [FLVNOO Supplier (FEAccou v] @
Company Code
=
Company Code KusH|[3 D Kush Private Limited [@ Company Codes ]
Customer [fﬁ Switch Company Code ]

Vendor 230001

Vendor: Payment Transactions | Vendor: Correspondence / Ven...|] |« /[

' Account Management
Reconciliation acct 4400 VENDOR RECON

Head office
Sort key [—|

—
L

Business partner A90001 created E"IV

Identification category and type are maintained in this below path

Create Organization

[E | [Mperson [ Organization [') Group B | & = | % &b General Data Relationships = &1

Business Partner By Grouping [RS01 Business Partner v |
Create in BP role | 000000 Business Partner (G.. vl@]

@ Address VAddress Overview E Control VPayment Transactions Vsmtus VAddiﬁonaI Texts VTemniGIIdenﬁﬁGﬁon

Industries =
. Standard Industry System: Standard Industry System \ -
Industry iDTescr'pﬁon stnd Indu...
p O (]
O
O N
0 -
| v | —— <«
B Almdustry systems | Entry 0 of 0
Identification Numbers
External BP Number
IDType Description Identification number Responsible Institution Entry date |Valid from |valid To [T
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SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->identification numbers->Define identification Categories

SPRO->SAP Reference IMG->Cross Application Components->SAP Business Partner->Business Partner-
>Basic Settings->identification numbers->Define identification types

visplay 1MG
% 3] 00 Existing BC Sets &y*BC Sets for Activity &y Activate
structure
» l_e:-:, CAD Integration
[63  Plant Data Collection
P Time Sheet

Financial Conditions
Calendar Upload for Financial Services
General Application Functions
Advanced Available-to-Promise (3ATP)
Bank Directory
Payment Cards
SAP Business Partner
* [e3 & Activation Switch for Functions
v Business Partner
i Basic Settings
Business Partner Roles
Notes
Number Ranges and Groupings
Business Partner Types
Field Groupings
Screen Configuration
Authorization Management
Address Determination
Forms of Address
Data Origin
Identification Numbers
- [ Indentification Number Concept
* [¢3 @ Define Identification Categories
- &3 & IDefine Identification Types!
4 Tax Numbers -

4 ¥ v v v v v w w
g/ g/
g7

Ty

4 ¥ v v v v v v wv wv w
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Create Partner Roles:

SPRO->SAP Reference IMG->Material Management->Purchasing->Partner Determination->Partner
Roles->Define Partner Roles

Change View "Definition of Partner Roles": Overvi
5% NewEntres (D B2 9O B B B (&

Funct |Name

PI
RT

Invoicing Party
Communication PartyR
Spec.stock partner
Suppler CD Warehouse

Customer type 4
Forwarding Agent
Mat.Safety Sheet Rec
Position resp.

Goods Seller

Addtnl. Notify Party
Prepaid Agrmt. Party
Prepaid Bil-To
Prepaid Payer
Collect Agrmt. Party
Collect Bil-To

Collect Payer

NoT... Unique
LI O
AP
KU
L1
L1

R IR TR TR RE AR - A |

HigherPar.... . [

Using already created Partner functions

Assign Partner Roles to Account Group:

SPRO->SAP Reference IMG->Material Management->Purchasing->Partner Determination->Partner
Roles->Define Permissible partner roles per account group

New Entries: Overview of Added Entries

YEERE

Define Partner Schema:

PI

Funct |Name
VN Vendor
OA Ordering address

Invoicing Party

Group 'Name

DIL1 Domestic Data
DIL1 Domestic Data
DIL1 Domestic Data

SPRO->SAP Reference IMG->Material Management->Purchasing->Partner Determination->Partner

settings in supplier master record->Define partner schemas

Here we have all the partner function/role and we can choose which partner role to make “No change”,
“Partner Mandatory”

VAISHNAVI JINDAM




View "Partner Schemas Supplier Master"” Change: Overvie
&% NeweEntries [[) B2 © [ | [£ [

Dialog Structure | ParSc Description
~{= Partner determination procedures | | |sceM vendor -
+ [(3 Partner Functions in Procedure v

SLYR Lyreco

SUPL Supplier

ZAN1 ANO1 Supplier Schema
ZPJ1 PJO1 Supplier Schema
ZPJ4 PJ04 Supplier Schema
ZVB VB Partner Schema

If you check on Partner functions in procedure the below screen appears

View "Partner Sch: ier Master" Ch. Overview
5 Newknties D EE O B & B [&

Dialog Structure
~ [ Partner determination procedures
* [£= Partner Functions in Procedure

PartnDet.Proc. SCHM

Funct Name No Chnge  Mand.
AD  Additionals (] O

CP  Contact person O O

AP A.payment recipient ‘ [

OR  Ordering address O vl

FS  Freight supplier O vl

VN Vendor [V vl

PI  Invoicing Party O [ pay
CR  Forwarding Agent [ [ -

Entry 1 of 11

Assign Partner Schema to account groups:

SPRO->SAP Reference IMG->Material Management->Purchasing->Partner Determination->Partner
settings in supplier master record->Assign Partner Schemas to account groups

Change View "Assignment of Partner Schemas to Accot

O E R E o

Group 'Name PS EKORG PS VSR PS PIt
r =
DIL1 Domestic Data SCHM SCHM LSCHM } —
Created BP

Here only vendor-VN is not editable

For other partner functions we can select different vendor
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Change Organization: 100001005, role Supplier
& gt

(2] | [YPerson [ Organization [ ) Group =]

Business Partner 100001005

Change in BP role FLVNO1 Supplier (Maintained) v @j

Purchasing Organization

General Data ¢

Relationships | &1

TEST Partner Fuction / 565656 Banglore

Purch. organization CORG Dil Kush Pur Org I-@ Purchasing Organizations ]
[ ﬁ Switch Organization J
Purchasing Data /(Partner Functions f Additional Purchasing Data - Interchangeability  Vendor: Texts - Supply Region
Partner Functions -

PF Partner Function Number Assigned BP Descript. Def
™ = —
SA Jiering address 100001002 100001005 TEST Partner Fuction -
FS Freight supplier 100001002 100001005 TEST Partner Fuction L v
VN Vendor 100001002 100001005 TEST Partner Fuction v
PI Invoicing Party 100001002 100001005 TEST Partner Fuction [

Action Path

Create Number Range for Account Group (XKN1)

Assign Number Range to account groups (OBAS)

Define Business Partner Number Range

Assign Business Partner Number range to
Grouping

Link Grouping and Account Group

SPRO->SAP Reference IMG->Financial
Accounting->Accounts Receivable and Payable-
>Vendor Accounts->Master Data->Preparation
of creating vendor master data->Define account
groups with screen layout (vendors)

SPRO->SAP Reference IMG->Financial
Accounting->Accounts Receivable and Payable-
>Vendor Accounts->Master Data->Preparation
of creating vendor master data->Create number
ranges for vendor accounts

SPRO->SAP Reference IMG->Financial
Accounting->Accounts Receivable and Payable-
>Vendor Accounts->Master Data->Preparation
of creating vendor master data->Assign Number
range to vendor account groups

SPRO->SAP Reference IMG->Cross Application
Components->SAP Business Partner->Business
Partner->Basic Settings->Number Ranges and
Groupings->Define number ranges

SPRO->SAP Reference IMG->Cross Application
Components->SAP Business Partner->Business
Partner->Basic Settings->Number Ranges and
Groupings->Define Groupings and assign
number ranges

SPRO->SAP Reference IMG->Cross Application
Components->Master Data Synchronization-
>Custom/Vendor integration->Business Partner
Settings->Settings for vendor integration->Field
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BP Role

Create customizing view

If want to make any field as mandatory or
optional or hide based for BP role we can do in
below path

If we want to select externally we need to select
flexible group and de-select “same number
range”

Or else you get the error as below because
different account groups have different number
ranges

Identification category and type

Create Partner Roles

Assign Partner Roles to Account Group

Define Partner Schema

Assign Partner Schema to account groups

assignment for vendor integration->Assign Keys-
>Define number assignment for direction BP to
vendor

SPRO->SAP Reference IMG->Cross Application
Components->SAP Business Partner->Business
Partner->Basic Settings->Business Partner Roles-
>Define BP Roles

BUSD

SPRO->SAP Reference IMG->Cross Application
Components->SAP Business Partner->Business
Partner->Basic Settings->Field Groupings-
>Configure Field Attribute per BP role
SPRO->SAP Reference IMG->Cross Application
Components->Master Data Synchronization-
>Custom/Vendor integration->Business Partner
Settings->Settings for vendor integration->Field
assignment for vendor integration->Assign Keys-
>Define number assignment for direction BP to
vendor

SPRO->SAP Reference IMG->Cross Application
Components->SAP Business Partner->Business
Partner->Basic Settings->identification numbers-
>Define identification Categories

SPRO->SAP Reference IMG->Cross Application
Components->SAP Business Partner->Business
Partner->Basic Settings->identification numbers-
>Define identification types

SPRO->SAP Reference IMG->Material
Management->Purchasing->Partner
Determination->Partner Roles->Define Partner
Roles

SPRO->SAP Reference IMG->Material
Management->Purchasing->Partner
Determination->Partner Roles->Define
Permissible partner roles per account group
SPRO->SAP Reference IMG->Material
Management->Purchasing->Partner
Determination->Partner settings in supplier
master record->Define partner schemas
SPRO->SAP Reference IMG->Material
Management->Purchasing->Partner
Determination->Partner settings in supplier
master record->Assign Partner Schemas to
account groups
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Thank you for reading!




